Chat Platform Outage
Incident Report for Peloton
Resolved
The incident previously impacting our chat platform has been resolved.
Posted Apr 04, 2024 - 12:11 EDT
Investigating
We are investigating an issue that is affecting our chat platform. If you need assistance, please reach out to our US Support Team via phone at 1-866-679-9129.

We apologize for any inconvenience this may cause.
Posted Apr 04, 2024 - 10:59 EDT
This incident affected: Contact (Chat).