Phone Queueing Delay
Incident Report for Peloton
Resolved
This incident has been resolved.
Posted Jan 13, 2021 - 18:49 EST
Investigating
We are currently investigating an issue with our telephone lines and are currently not available by phone. Our sales team is available by Chat at https://www.onepeloton.com and our Support team is available by Chat at https://support.onepeloton.com. We apologize for any inconvenience while we investigate.
Posted Jan 13, 2021 - 17:17 EST
Identified
The Peloton team has identified the cause of the issue but has not yet implemented a fix or workaround.
Posted Jan 13, 2021 - 16:57 EST
This incident affected: Contact (Phone).