Video On-Demand playback Issues
Incident Report for Peloton
Resolved
This incident has been resolved.
Posted Apr 20, 2022 - 09:03 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 19, 2022 - 23:31 EDT
Investigating
We are investigating an issue with Peloton classes. This may impact your selection of a small number of on-demand classes, where the class may delay or stall a few seconds after joining.
Posted Apr 19, 2022 - 17:32 EDT
This incident affected: Bike/Tread/App (Live Classes, On Demand Classes, Peloton App).