Rider Profile/Workout History
Incident Report for Peloton
Resolved
We released a fix for this issue and the issue is resolved. Your Bike will update automatically when you turn on your touchscreen. Thank you for your patience and we apologize for the inconvenience.
Posted 10 months ago. Aug 17, 2018 - 17:21 EDT
Monitoring
We just released a fix for this issue. Your Bike will update automatically when you turn on your touchscreen. Thank you for your patience and we apologize for the inconvenience.
Posted 10 months ago. Aug 17, 2018 - 12:44 EDT
Identified
We are continuing to investigate an issue with some Members not being able to log into the Peloton Bike. To resolve the issue, please follow the instructions below on how to uninstall the latest update:

Go to Device Settings (top right-hand corner of the touchscreen) > Apps > Peloton
Tap the three dots on the top right
Select Uninstall Updates
Tap the Peloton logo
Posted 10 months ago. Aug 16, 2018 - 17:51 EDT
Investigating
We are investigating an issue with members logging into the Peloton bike. This may impact your ability to log in on your Peloton bike.
Posted 10 months ago. Aug 16, 2018 - 16:43 EDT
This incident affected: Rider Profile/Workout History.