Phone Outage
Incident Report for Peloton
Resolved
This incident has been resolved.
Posted Dec 10, 2021 - 17:42 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 10, 2021 - 16:09 EST
Investigating
We are currently investigating an issue with our phone platform that is preventing incoming phone calls from connecting with our associates. Our team is available to chat at support.onepeloton.com.
Posted Dec 10, 2021 - 15:48 EST
This incident affected: Contact (Phone).