Chat Routing Issue
Incident Report for Peloton
Resolved
This incident has been resolved.
Posted Sep 17, 2021 - 17:39 EDT
Investigating
We are currently investigating an issue with chat routing that may delay chat routing to our Support associates.
Posted Sep 17, 2021 - 10:25 EDT
This incident affected: Contact (Chat).