Issue Streaming Robins 30 min Hamilton Ride
Incident Report for Peloton
Resolved
This incident has been resolved. We apologize for any interruption to your workout.
Posted Oct 17, 2020 - 14:41 EDT
Investigating
We are investigating an issue with Robins 30 minute Hamilton ride. The team is investigating the issue.
Posted Oct 17, 2020 - 13:38 EDT
This incident affected: Bike/Tread/Digital (On Demand Classes).