Issue Activating Peloton Bike
Incident Report for Peloton
Resolved
We released a fix for this issue and the issue is resolved. Your Bike will update automatically when you turn on your touchscreen. Thank you for your patience and we apologize for the inconvenience.
Posted 8 months ago. Aug 21, 2018 - 16:12 EDT
Investigating
We are investigating an issue with members activating their Peloton bike. This may impact your ability to log in and activating and logging into the bike.
Posted 8 months ago. Aug 21, 2018 - 16:03 EDT
This incident affected: Rider Profile/Workout History.