Issue syncing Workouts to Apple Heath
Incident Report for Peloton
Resolved
We have resolved the issue with Apple Health syncing on the Peloton Digital iOS App. To solve the issue, we recommend updating your iOS app to version 10.4.1. Thank you for your patience as we worked to resolve this.
Posted 4 months ago. Feb 18, 2019 - 17:25 EST
Identified
We are aware that many of you are experiencing issues syncing your Peloton workouts to the Apple Health App. We have temporarily disabled this feature while our team works to resolve this issue as quickly as possible.

We sincerely apologize for the inconvenience and appreciate your patience. We will make sure to provide another update once it is working properly.
Posted 4 months ago. Feb 16, 2019 - 16:41 EST
This incident affected: Peloton Digital.