Studio.onepeloton.com slow to load
Incident Report for Peloton
Resolved
We have resolved the issue with the studio.onepeloton.com load time issues.
Posted 8 months ago. Oct 16, 2018 - 06:50 EDT
Investigating
We are investigating intermittent issues on studio.onepeloton.com. Viewing the schedule and reserving classes is slow to load. Refreshing the page should resolve the issue.
Posted 8 months ago. Oct 15, 2018 - 22:34 EDT
This incident affected: Website (Peloton Studio (studio.onepeloton.com)).