Issue with On-Demand Classes on Web
Incident Report for Peloton
Resolved
This incident has been resolved.
Posted Dec 10, 2019 - 13:35 EST
Update
We are currently experiencing issues with streaming On-Demand classes on web. We are investigating and will update with more information.
Posted Dec 10, 2019 - 11:05 EST
Investigating
We are currently experiencing issues with streaming On-Demand classes on web. We are investigating and will update with more information.
Posted Dec 10, 2019 - 11:03 EST