Scheduled leaderboard maintenance
Incident Report for Peloton
Resolved
The scheduled maintenance with the Leaderboard has now been resolved.
Posted about 2 years ago. Jul 28, 2017 - 09:13 EDT
Monitoring
We will be conducting scheduled maintenance on our leaderboard on Friday July 28, 2017 at 3 am ET (12 am PT). During this time, the leaderboard will not function for live or on-demand classes. We do not expect this maintenance to last more than 30 minutes. Thank you for understanding.
Posted about 2 years ago. Jul 27, 2017 - 14:54 EDT