Chat Routing Failure
Incident Report for Peloton
Resolved
This incident has been resolved.
Posted Feb 02, 2021 - 18:36 EST
Update
We are continuing to investigate this issue.
Posted Feb 02, 2021 - 17:39 EST
Investigating
We are currently investigating an issue with chat routing that may stop you from connecting directly to our Support agents. You can best contact us via our Support Line at 866-679-9129. We apologize for the inconvenience while we work through this issue.
Posted Feb 02, 2021 - 17:35 EST
This incident affected: Contact (Chat).