Peloton 101 Does Not Load
Incident Report for Peloton
Resolved
This incident has been resolved.
Posted 20 days ago. Aug 29, 2019 - 23:06 EDT
Identified
We have identified an issue with Peloton 101. This may impact your ability to view Peloton 101 content. While our team fixes the issue, you can view our getting started video here that goes over everything you need to get started for your first ride: https://www.youtube.com/watch?v=vDInG0S13tM&t=
Posted 20 days ago. Aug 29, 2019 - 22:03 EDT