Peloton App Login Issues
Incident Report for Peloton
Resolved
The issues with logging in have been resolved.
Posted Mar 09, 2022 - 19:43 EST
Monitoring
Our Team is investigating an issue with the Peloton App that is impacting members' ability to log in to their account. A fix has been pushed and we are beginning to see recovery. We will continue to monitor the situation.
Posted Mar 09, 2022 - 13:59 EST
This incident affected: Bike/Tread/App (Member Login).