Issue accessing members.onepeloton.com
Incident Report for Peloton
Resolved
The issues with members.onepeloton.com have now been resolved.
Posted Aug 03, 2018 - 16:39 EDT
Investigating
The team is actively investigating an issue where some Members cannot access members.onepeloton.com.
Posted Aug 03, 2018 - 16:24 EDT
This incident affected: Website (Peloton Profile/Workout History (members.onepeloton.com)).