Financing on our website
Incident Report for Peloton
Resolved
This incident has been resolved.
Posted over 2 years ago. Dec 29, 2016 - 13:14 EST
Investigating
The functionality to finance a bike purchase on our website is currently unavailable. Our team is investigating the issue now. In the meantime, if you'd like to purchase a bike with financing, you can still do so by calling us at 866-679-9129
Posted over 2 years ago. Dec 29, 2016 - 11:00 EST