Unable to Log into Peloton Account

Incident Report for Peloton

Resolved

This incident has been resolved.
Posted Aug 25, 2026 - 14:13 EDT

Investigating

Members are currently unable to log into Peloton across all surfaces (Bike, Tread, Row, App, Web). Team is investigating.
Posted Aug 25, 2026 - 14:01 EDT
This incident affected: Bike/Tread/App/Row (Member Login).