Activation Issues
Incident Report for Peloton
Resolved
This incident has been resolved.
Posted Aug 07, 2020 - 14:18 EDT
Monitoring
We have identified some issues activating devices. We have implemented a fix and are monitoring now.
Posted Aug 07, 2020 - 14:14 EDT
This incident affected: Bike/Tread/Digital (Activation).