Users encounter an endless loading spinner on Android Watch when attempting to detect heart rate after updating to app version 3.67.0.

Incident Report for Peloton

Identified

The issue has been identified and we are working on rolling out a fix.
Posted Apr 14, 2026 - 13:17 EDT

Investigating

We are currently investigating the issue.
Posted Apr 14, 2026 - 12:28 EDT
This incident affects: Bike/Tread/App/Row (Peloton App).