Missing Information on Homepage
Incident Report for Peloton
Resolved
This incident has been resolved.
Posted Dec 05, 2024 - 17:42 EST
Investigating
Team is investigating an issue preventing streak and workout information from displaying the homepage.
Posted Dec 05, 2024 - 16:54 EST
This incident affected: Bike/Tread/App/Row (Peloton App, Connected Fitness Tablets).