Incoming email issue
Incident Report for Peloton
Resolved
This incident has been resolved.
Posted Feb 27, 2020 - 11:49 EST
Investigating
We are currently investigating an issue with accepting email at some specific addresses, including apparel@onepeloton.com, homecoming@onepeloton.com, kontakt@onepeloton.de, and some others. We will update this page when have more information on this issue.
Posted Feb 27, 2020 - 10:09 EST
This incident affected: Contact (Support Tickets).