Phone Routing Issues
Incident Report for Peloton
Resolved
This incident has been resolved.
Posted 2 months ago. Aug 12, 2019 - 15:07 EDT
Monitoring
We are seeing a restoration of phone services and support agents are beginning to answer calls. We will keep monitoring this issue further.
Posted 2 months ago. Aug 12, 2019 - 13:13 EDT
Investigating
We apologize, but we are currently experiencing an issue with receiving calls to our Support team. Our team is available to help immediately over chat at support.onepeloton.com if you need assistance.
Posted 2 months ago. Aug 12, 2019 - 13:06 EDT
This incident affected: Website (Peloton Support (support.onepeloton.com)).