On-demand classes
Incident Report for Peloton
Resolved
We have resolved the Leaderboard performance issues with on-demand classes. We apologize for any interruption to your workout.
Posted Apr 18, 2020 - 21:29 EDT
Investigating
We are investigating a Leaderboard performance issue with on-demand classes.
Posted Apr 18, 2020 - 21:17 EDT
This incident affected: Bike/Tread/App/Row (Leaderboard).