Checkout Page Issues.
Incident Report for Peloton
Resolved
This incident has been resolved.
Posted Jul 26, 2022 - 12:31 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 25, 2022 - 16:39 EDT
Update
We are continuing to investigate this issue.
Posted Jul 25, 2022 - 11:07 EDT
Investigating
We are currently investigating intermittent issues with our checkout page and login page. This issues is not affecting all members but if you are experiencing an issue we recommend trying to reload the page.
Posted Jul 25, 2022 - 10:53 EDT
This incident affected: Retail/Studio (In-Store Purchases) and Website (Peloton Checkout (onepeloton.com/checkout)).