Reserving In Studio Classes Experiencing Degraded Service

Incident Report for Peloton

Resolved

This incident has been resolved.
Posted Jul 21, 2022 - 13:52 EDT

Monitoring

Members are reporting they are able to reserve workouts at the studios. We are closely monitoring the situation to ensure the issue is fully resolved.
Posted Jul 19, 2022 - 15:57 EDT

Investigating

We are currently investigating studio reservations on studio.onepeloton.com working intermittently. We recommend trying to reserve a studio class later.
Posted Jul 18, 2022 - 13:04 EDT
This incident affected: Website (Peloton Studio (studio.onepeloton.com)).