Apple Watch Series 3 Peloton App crashing on launch

Incident Report for Peloton

Monitoring

A fix has been implemented and a new iOS version has begun rolling out to members. Please download v.15.125.0
Posted Jun 01, 2026 - 09:42 EDT

Identified

This issue is impacting anyone with an Apple Watch Series 3, watchOS 8 and on Peloton App Version 15.124.0.   A fix has been identified and is including in our next release that will roll out starting on 6/1.
Posted May 29, 2026 - 14:53 EDT

Investigating

Team is investigating an increase error with with Watch App tied to the latest app release 15.124.0 and WatchOS8
Posted May 29, 2026 - 11:51 EDT
This incident affects: Bike/Tread/App/Row (Peloton App, Connected Fitness Tablets).