Member Login Issue
Incident Report for Peloton
Resolved
This incident has been resolved. We apologize for any interruption to your workout.
Posted Jul 27, 2023 - 11:34 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 27, 2023 - 08:39 EDT
Identified
Our Team has identified the issue affecting login on the Peloton Web App (members.onepeloton.com) and is working on a fix.
Posted Jul 27, 2023 - 07:19 EDT
This incident affected: Bike/Tread/App/Row (Member Login) and Website (Peloton Profile/Workout History (members.onepeloton.com)).