Used Equipment Activation Fee Checkout Issue

Incident Report for Peloton

Resolved

This incident has been resolved.
Posted Sep 30, 2024 - 22:12 EDT

Investigating

Team is investigating an issue with activating subscriptions on pre-owned equipment.
Posted Sep 30, 2024 - 17:29 EDT
This incident affected: Bike/Tread/App/Row (Activation).