Support Chat Unavailable
Incident Report for Peloton
Resolved
This incident has been resolved.
Posted Apr 14, 2020 - 19:12 EDT
Update
We are working on an issue with creating chats with the support team. We are currently working with our partners to fix this issue as soon as possible. In the meantime, you can still contact support by calling us at (866) 679-9129.
Posted Apr 14, 2020 - 17:57 EDT
Identified
We are working on an issue with creating chats with the support team. We are currently working with our partners to fix this issue as soon as possible. In the meantime, you can still contact support by calling us at (866) 679-9129.
Posted Apr 14, 2020 - 17:57 EDT
This incident affected: Contact (Chat).