Some members are experiencing an issue updating their tablet.

Incident Report for Peloton

Resolved

This incident has been resolved.
Posted Feb 28, 2025 - 09:07 EST

Investigating

The team is investigating this issue. If you encounter an issue updating your device, turn the screen off and back on and the update should proceed as normal.
Posted Feb 27, 2025 - 22:50 EST