Issue with Live or On-Demand Classes
Incident Report for Peloton
Resolved
This incident has been resolved.
Posted Apr 08, 2022 - 15:58 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 01, 2022 - 01:46 EDT
Update
We are continuing to investigate this issue.
Posted Mar 31, 2022 - 11:22 EDT
Investigating
We are investigating an issue with Peloton classes. This may impact your selection with live or on-demand classes, where the wrong class is playing when a specific class is joined.
Posted Mar 31, 2022 - 11:11 EDT
This incident affected: Bike/Tread/App (Live Classes, On Demand Classes).