Issue Activating Bikes in Australia
Incident Report for Peloton
Resolved
Our team has resolved issues with activating bikes in Australia. For any members still experiencing an issue loading a class, please make sure your Peloton Bike's time zone settings are correct in Device settings -> System -> Date & Time
Posted Oct 07, 2021 - 22:30 EDT
Investigating
We are investigating an issue with activating bikes in Australia.
Posted Oct 07, 2021 - 20:56 EDT
This incident affected: Bike/Tread/Digital (Activation).