Class Notes are currently unavailable on iOS, Android and CFX platforms.

Incident Report for Peloton

Resolved

This issue has been resolved.
Posted Aug 27, 2026 - 11:57 EDT

Monitoring

A fix has been implemented and we are monitoring results.
Posted Aug 27, 2026 - 10:29 EDT

Investigating

We are currently investigating an issue where class notes do not appear on iOS, Android and CFX platforms.
Posted Aug 27, 2026 - 10:08 EDT
This incident affected: Bike/Tread/App/Row (Peloton App).