Bike/Tread Activation Issue
Incident Report for Peloton
Resolved
This incident has been resolved.
Posted Oct 20, 2021 - 16:50 EDT
Investigating
We are currently investigating an issue where some members are unable to activate a new Bike or Tread. If you are having any issues with activation, please call our support team at 1 (866) 679-9129 for assistance. We apologize for any impact this may have on your workout.
Posted Oct 20, 2021 - 10:40 EDT
This incident affected: Bike/Tread/App/Row (Activation).