AU Affirm Integration Interruption

Incident Report for Peloton

Resolved

This incident has been resolved.
Posted Jun 30, 2022 - 15:53 EDT

Investigating

We are investigating an issue with financing purchases using Affirm in AU. We recommend trying to make your purchase later. We apologize for any inconvenience.
Posted Jun 15, 2022 - 12:06 EDT
This incident affected: Integrations (Affirm).