Chat Platform Outage
Incident Report for Peloton
Resolved
This incident has been resolved.
Posted Mar 23, 2023 - 21:44 EDT
Monitoring
A fix has been implemented and we are monitoring the results. We appreciate your patience and understanding during this incident.
Posted Mar 23, 2023 - 20:58 EDT
Investigating
We are investigating an issue that is affecting our chat platform. If you need assistance, please reach out to our Support Team via phone:

United States- 1-866-679-9129
Canada- (833) 821-0099
United Kingdom- +44 (0) 808 169 6469
Germany- 0800-0001841
Australia-1800 952 535

We apologize for any inconvenience this may have caused.
Posted Mar 23, 2023 - 07:39 EDT
This incident affected: Contact (Chat).