Peloton Phone System Enhancements
Incident Report for Peloton
Resolved
Our phone system upgrade is now fully complete. We sincerely appreciate your understanding during this change.
Posted Jul 06, 2022 - 09:49 EDT
Identified
Peloton is undergoing a significant improvement in our phone system. As part of this change, some of our phone numbers are temporarily unavailable or have been replaced by new numbers. We recommend connecting with us over chat if you need immediate assistance as we upgrade our systems.

If you need help in Australia, please visit support.onepeloton.com.au
If you need help in Canada, please visit support.onepeloton.ca
If you need help in Germany, please visit support.onepeloton.de
If you need help in the US, please visit support.onepeloton.com
If you need help in the UK, please visit support.onepeloton.co.uk

We appreciate your understanding.
Posted Jun 01, 2022 - 19:24 EDT
This incident affected: Contact (Phone).