Phone System Issue
Incident Report for Peloton
Resolved
This incident has been resolved.
Posted Aug 27, 2021 - 07:54 EDT
Monitoring
A fix has been implemented for our phone system and we are beginning to see recovery. We are continuing to validate and monitor the status.
Posted Aug 26, 2021 - 16:11 EDT
Identified
We have observed an additional issue with our phone platform that is preventing some incoming calls from connecting with our associates.
Posted Aug 26, 2021 - 14:57 EDT
Monitoring
A fix has been implemented for our phone system and we are beginning to see recovery. We are continuing to validate and monitor the status.
Posted Aug 26, 2021 - 14:16 EDT
Investigating
We are currently investigating an issue with our phone platform that is preventing some incoming phone calls from connecting with our associates.
Posted Aug 26, 2021 - 13:21 EDT
This incident affected: Contact (Phone).