Peloton Website Degraded Performance
Incident Report for Peloton
Resolved
The issues with onepeloton.com's performance have now been resolved.
Posted Jun 07, 2023 - 12:23 EDT
Investigating
We are investigating an issue with onepeloton.com. This may impact your ability to browse, shop, or log in.
Posted Jun 07, 2023 - 12:19 EDT
This incident affected: Website (Peloton Site - (onepeloton.com)).