Sketch rendering issues and degradation
Incident Report for Peloton
Resolved
This incident has been resolved.
Posted May 20, 2020 - 14:50 EDT
Update
We are continuing to investigate this issue.
Posted May 20, 2020 - 14:21 EDT
Investigating
We are currently investigating issues with this service.
Posted May 20, 2020 - 14:14 EDT