Issue with onepeloton.co.uk and onepeloton.com/en-AU

Incident Report for Peloton

Resolved

This incident has been resolved.
Posted Nov 06, 2025 - 13:39 EST

Update

We are continuing to monitor for any further issues.
Posted Nov 06, 2025 - 12:06 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 06, 2025 - 12:06 EST

Identified

We are currently experience issues with our website in Australia and the UK. Team has identified the issue and working to resolve.
Posted Nov 06, 2025 - 10:16 EST
This incident affected: Website (Peloton Site - (onepeloton.com)).