Peloton Profile/Workout History Issue
Incident Report for Peloton
Resolved
This incident has been resolved.
Posted May 04, 2023 - 15:00 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 04, 2023 - 13:39 EDT
Investigating
We are investigating an issue with how data is displaying/saving to rider profiles. This may impact your ability to view workout history, performance, and achievements. Your class history may be incomplete when viewed on your Peloton profile.
Posted May 04, 2023 - 13:32 EDT
This incident affected: Website (Peloton Profile/Workout History (members.onepeloton.com)).