Members unable to update Personalized Plans preferences and start new plans

Incident Report for Peloton

Resolved

This incident has been resolved.
Posted Aug 20, 2025 - 12:09 EDT

Monitoring

The team has resolved the issue and is monitoring. Members should be able to start and update plan preferences now.
Posted Aug 20, 2025 - 12:04 EDT

Investigating

We are currently investigating this issue.
Posted Aug 20, 2025 - 11:58 EDT