Touchscreen Issue
Incident Report for Peloton
Resolved
This incident has been resolved.
Posted Oct 01, 2021 - 09:54 EDT
Update
An updated fix for this issue has been deployed. If you are still experiencing an issue with your touchscreen, please visit https://support.onepeloton.com/hc/en-us/?utm_campaign=touchscreen for additional assistance. We sincerely apologize for any interruption to your workout.
Posted Sep 21, 2021 - 21:08 EDT
Update
A fix has been implemented for this issue but additional steps may be required on your device. Please visit https://support.onepeloton.com/hc/en-us/?utm_campaign=touchscreen for assistance.
Posted Sep 20, 2021 - 14:13 EDT
Monitoring
We will continue to post Status Updates as we monitor this issue.
Posted Sep 20, 2021 - 11:21 EDT
Identified
We have identified an issue with touchscreens on connected fitness devices. We are working to resolve the issue and will continue to provide updates on the Status Page.
Posted Sep 20, 2021 - 11:02 EDT
This incident affected: Bike/Tread/App/Row (Member Login, Live Classes, On Demand Classes, Leaderboard, Activation).