Issue with Checkout
Incident Report for Peloton
Resolved
This incident has been resolved.
Posted Jul 27, 2022 - 15:10 EDT
Update
We are continuing to investigate this issue.
Posted Jul 27, 2022 - 14:39 EDT
Investigating
We are investigating an issue with checking out on our website. We recommend trying to complete your purchase later. We apologize for any inconvenience
Posted Jul 27, 2022 - 14:33 EDT
This incident affected: Integrations (Checkout).