AWS Outage

Incident Report for Peloton

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 07:48 EDT

Monitoring

The core Peloton workout experiences are back in an operational state. Team continues to monitor all services.
Posted Oct 20, 2025 - 16:21 EDT

Investigating

We are seeing another spike in errors across several Peloton services. The team is investigating with our partners.
Posted Oct 20, 2025 - 11:11 EDT

Monitoring

We are seeing recovery from the AWS outage and are actively monitoring all platforms and services.

There may be delays in Insights and Recommendations as we wait for full recovery.
Posted Oct 20, 2025 - 06:05 EDT