OnePeloton.com Website
Incident Report for Peloton
Resolved
This incident has been resolved.
Posted Oct 01, 2019 - 19:12 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 01, 2019 - 19:08 EDT
Update
We are continuing to investigate this issue.
Posted Oct 01, 2019 - 18:43 EDT
Investigating
We are currently investigating an issue with our website at onepeloton.com causing the page not to load. We will update this page with updates.
Posted Oct 01, 2019 - 18:43 EDT
This incident affected: Website (Peloton Site - (onepeloton.com)).