Issue with Live or On-Demand Classes
Incident Report for Peloton
Resolved
The issue with a small number of Members experiencing streaming issues has been resolved. We apologize for any interruption to your workout.
Posted Jun 09, 2023 - 17:17 EDT
Investigating
We are investigating an issue with Peloton classes streaming performance. This may impact your ability to take live or on-demand classes.
Posted Jun 07, 2023 - 11:40 EDT
This incident affected: Bike/Tread/App/Row (Live Classes, On Demand Classes).