Live classes
Incident Report for Peloton
Resolved
The performance issues with the live class have been resolved.
Posted May 07, 2020 - 14:29 EDT
Investigating
We are investigating an issue with our 12 PM ET class with Jenn Sherman. This may impact your ability to take a live class.
Posted May 07, 2020 - 12:30 EDT
This incident affected: Bike/Tread/Digital (Live Classes).